Sujets-libres.fr

Informatique, logiciels libres, internet, humeurs et… le reste !

Défaillance de mon imprimante 3D

Rédigé par -Fred- Aucun commentaire

Dernièrement au cours d'une impression, à l'instant précis où mon plateau chauffant atteignait la température désirée, mon imprimante a cessé de fonctionner. Pour être plus précis, la température du plateau a commencé à descendre. Mon plateau chauffant ne réagissait plus tandis que l'imprimante répondait correctement par ailleurs.

L'origine de la défaillance est présentée en photo ci-dessous. Mon plateau chauffant n'était tout simplement plus alimenté car la câble était sectionné au niveau du connecteur sur la carte RAMPS 1.4.


Avant de réparer, j'ai quand même envie de savoir ce qui s'est produit car ça n'arrive jamais par hasard. Comme on peut le voir, le connecteur est complètement fondu. De plus, le câble côté 12V est dénudé et on peut voir que c'est là que le circuit est coupé (les bruns sont bien visibles). Petite précision concernant mon imprimante et la liaison entre ma carte RAMPS 1.4 et mon plateau chauffant : la position du câble varie en fonction de la position du plateau (normal).

Il est donc très probable que le fil d'alimentation ai travaillé et qu'une partie des bruns aient sectionné à l'intérieur de la gaine. Cela aura eu pour effet de réduire la section du câble. Pour rappel, le plateau chauffant consomme plus que tout le reste dans l'imprimante (11A sous 12V). Donc localement, le câble a anormalement chauffé (faible section du câble => résistance plus importante à cet endroit => P=R*I^2 => plus de pertes par effet Joule).

Tout ça pour dire qu'il ne suffit pas ici de réparer mais qu'il faut aussi faire le nécessaire pour que le câble ne travaille pas sous peine de le recasser de nouveau. Je vais aussi être plus attentif vis à vis de l'état de la machine, ce qui me permettra de faire de la maintenance préventive plutôt que du curatif comme ici. Cette défaillance aurait pu avoir des conséquences bien plus graves et ça me pousse à dire qu'une imprimante 3D ne doit pas fonctionner sans surveillance.

Imprimante 3D en action

Rédigé par -Fred- 2 commentaires

Les photos, c'est bien, mais une petite vidéo en plus, c'est intéressant aussi :

Comme le montre cette vidéo, certaines des pièces ont été imprimées par la machine elle même, notamment la partie liée à la ventilation de la buse et celle de la pièce. Sur la vidéo, j'imprime un support de fin de course.

Au niveau des réglages, c'est presque OK. Je publierai une dernière série de photos de pièces lorsqu'elle seront correctes.

Note : j'ai volontairement un peu réduit la qualité de la vidéo dans la mesure où comme mon blog, elle est auto-hébergée derrière ma ligne ADSL.

Pi <-> Pot à crayon de bureau

Rédigé par -Fred- Aucun commentaire

Les problèmes de fuites au niveau du bloc de chauffe semblent à présent résolus. J'ai pu faire quelques essais cette semaine et voici le dernier résultat en date :


Le résultat n'est pas parfait mais il ressemble quand même à quelque chose :p. La réalisation a duré environ 5h30 (ce qui me fait d'ailleurs voir qu'un dérouleur, ce n'est du luxe finalement). Le modèle original se trouve à l'adresse suivante : http://www.thingiverse.com/thing:271769

Mes premières impressions à propos ... de l'impression 3D

Rédigé par -Fred- 2 commentaires

Après quelques semaines sans nouvelles de l'avancement du montage de mon imprimante 3D, en voici quelques unes. Les retours que je propose (et proposerai encore) à ce sujet ont ceci d'utile qu'ils correspondent à ceux de quelqu'un ayant peu de connaissances solides à tout ce qui touche à l'impression 3D.

La fin de l'assemblage

J'ai reçu ma tête d'impression et une bobine de PLA début février et j'ai donc été en mesure de terminer le montage de l'imprimante et de mettre la machine en marche. J'ai opté pour un Kit Hexagon (trouvé sur Reprap France) qui, s'il est bien livré avec son ventilateur, demande quand même à réaliser quelques adaptations pour que le refroidissement soit efficace. Le filament utilisé est du 1,75 mm. La buse est est quand à elle en 0,4 mm.

Partie logicielle

Petit point synthétique sur la chaine logicielle que j'ai utilisé. Utile puisque pour le pur débutant, ça peut semble abscons et parce que ce point ne me semblait pas clair quand j'ai commencé à m'intéresser à l'impression 3D :

  • Firmware dans l'arduino de la reprap : Marlin
  • Logiciel de modélisation 3D : Pas encore fait mes propres modèles mais je pense que je commencerai par FreeCAD.
  • Logiciel permettant de générer le GCODE à partir du STL : Slic3r
  • Logiciel permettant de communiquer avec l'imprimante et de lui envoyer le fichier GCODE : Repetier Host

Point vraiment positif, l'ensemble de ces logiciels est sous licence libre :D .

Avant d'utiliser Repetier Host, j'ai utilisé Pronterface mais ce logiciel semblait avoir des problèmes avec la gestion de la liaison série, en tout cas chez moi (nombreuses pauses durant l'impression et donc, impossible de faire quoi que ce soit de propre dans mon cas). Aucun soucis à présent.

Mise au point et résolution des premiers problèmes

Je suis encore en phase de réglage et pour me faire la main, j'ai décidé de m'amuser avec un dé. Ça semble simple au premier abord mais je commence tout juste à arriver à un résultat acceptable. Globalement, passé les réglages de base, je suis dans une démarche assez empirique. Pour la mise au point, les liens suivants m'ont été utiles :

Voici quelques dés. C'est assez représentatif de l'avancée des réglages de la machine.

Le seul vrai problème que j'ai rencontré concerne une fuite au niveau de la tête d'impression. Je ne m'en suis pas rendu compte immédiatement car la tête chauffante n'est pas très visible dans mon installation. Cependant, après quelques impressions, de la matière brulée a commencé à se mélanger à celle que la machine posait. J'ai d'abord cru déposer trop de matière avant de comprendre que mon bloc de chauffe était mal serré à chaud et que tout le bloc était recouvert de matière plus ou moins brulée.

Ci-dessous, diverses tentatives d'impression d'une tasse. On voit nettement sur la dernière les traces de brulure dont je parle.

Bref, je l'ai complètement démontée et j'ai procédé à un premier nettoyage grossier au fer à souder (le plastique froid, ça ne bouge pas). Une fois là, j'ai remonté l'ensemble mais sans le mettre sur le charriot de déplacement en X afin d'avoir accès facilement au bloc de chauffe. J'ai alors mis la buse en chauffe de manière normale (à 230°c ; supérieur à la température normale d'utilisation chez moi car je ne travaille qu'avec du PLA), j'ai encore un peu nettoyé la tête avec des cotons tige et j'ai serré le bloc de chauffe à cet instant là. Une fois la machine complètement remontée et mise en marche, je n'ai pas constaté de fuite. Je continue à surveiller ça de près...

En tout cas, c'est fun et très formateur comme démarche (et ce n'est pas fini...).

Des nouvelles de l'imprimante 3D

Rédigé par -Fred- Aucun commentaire

Ça avance toujours et plusieurs problèmes ont été résolus récemment. Premier problème, le plus évident peut être, celui du câblage de l'électronique. J'ai donc opté pour l'ajout d'un gros support en medium sur le côté afin de fixer les cartes électroniques. J'ai aussi utilisé pas mal de gaines permettant de fixer les fils (et ils sont nombreux) au support. C'est vraiment pratique, surtout lorsque l'on souhaite y faire passer de nouveaux fils. Je n'ai pas non plus souhaité bidouiller une alimentation ATX spécialement pour cette imprimante (je préfère me garder la possibilité de pouvoir en changer ou d'utiliser celle en place temporairement pour un autre usage à l'occasion). J'ai donc simplement câblé les connecteurs qui vont bien dessus et le tour est joué.

Par ailleurs, j'ai aussi ajouté des petits ventilateurs de recup (12V ; 4 cm de diamètre) sur les moteurs de l'extrudeur, de l'axe X et de l'axe Y. J'ai en effet constaté que ces moteurs chauffaient assez vite. J'ai aussi prévu une ventilation pour la carte RAMPS. Globalement, je préfère agir de manière préventive. Rien de prévu pour les moteurs de l'axe Z car ils sont peu sollicités et qu'ils semblent très peu chauffer à l'usage (à confirmer ensuite en conditions normales...).

Voilà ce que donne la partie dont j'ai parlé :

Fil RSS des articles de ce mot clé